ニコニコチャンネルメニュー

ブロマガ - ニコニコチャンネル

AviUtlの小言

Failed to avformat_open_input.

2013/02/14 21:47 投稿

コメント:1

  • タグ:
  • AviUtl
※現在のL-SMASH Worksではこの問題は発生しません。
※問題を解決するだけなら更新した方が良いでしょう。
※ただし、プラグインの入力順位には確認し、気をつけた方が無難です。

AviUtlで動画を読み込もうとした際、この様なエラーが出る方はおられないでしょうか。

自分の環境では発生したことが無く、再現出来ずに解決策がわからなかったのですが、最近L-SMASH Worksを更新した際に発生し、ひとまず解決法を発見したので、こちらにも書いておこうと思います。

単刀直入に言えばこれは入力プラグインの優先順位の問題です。



上の画像の様に、Libav-SMASH File Reader拡張編集 File Reader より上になっているとこのエラーが発生してしまいます。
Libav-SMASH File Readerが上だと拡張編集 File Readerを介して読み込むべきファイルも、一旦Libav-SMASH File Readerで読み込もうとしてしまう為起きてしまうようです。
ひとまず、Libav-SMASH File Readerの優先度を下げると回避出来るようです。

また、JPEGなどをLibav-SMASH File Readerで読み込む様な優先順位にすると.lwiファイルが生成されてしまうので、備え付けのプラグインであるJPEG/PNG File Readerを上にしておきましょう。
※現在のverではJPEGなどは読み込まれず、このような事態は発生しないようですが、万が一、.lwiファイルが作成されてしまう事が起きた場合は試してみて下さい。

L-SMASH Woksプラグインは非常に便利な読み込みプラグインですが、理由が無い限り、
専用の入力プラグインが存在する形式のファイルは専用プラグインに任せた方が
無難であったり動作も早くなります。


今回の参考リンク
L-SMASH Worksプラグイン(の有名な配布元)POP@4bit




コメント

TNA
No.1 (2017/02/12 02:52)
それを試しても解決しないです。そもそもLibav-SMASH File Readeがありません。
コメントを書き込むにはログインしてください。

いまブロマガで人気の記事